Website unavailable for a small number of customers

Incident Report for Upstock

Resolved

This incident has been resolved.
Posted Oct 18, 2023 - 15:29 NZDT

Identified

The issue has been identified and we're rolling back the changes now.

A potential fix is to clear your browsers cache or use the mobile app which is unaffected.
Posted Oct 18, 2023 - 15:07 NZDT
This incident affected: Application (go.upstock.app).