Issue connecting to integrations

Incident Report for Upstock

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 17:29 NZST

Monitoring

A fix has been implemented. Users connected to the following integrations may need to reconnect: Xero, QuickBooks and Microsoft BC.

To do so, navigate to Settings > Integrations.
Posted Apr 16, 2026 - 17:07 NZST

Investigating

We've noticed an increased error rate connecting to and interacting with integrations.

The team are investigating the issue.
Posted Apr 16, 2026 - 16:29 NZST
This incident affected: Application (go.upstock.app).